您的位置:首页 > 其它

集训队专题(7)1003 Task Schedule

2016-02-27 16:23 295 查看


Task Schedule

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6422 Accepted Submission(s): 2024



Problem Description

Our geometry princess XMM has stoped her study in computational geometry to concentrate on her newly opened factory. Her factory has introduced M new machines in order to process the coming N tasks. For the i-th task, the factory has to start processing it
at or after day Si, process it for Pi days, and finish the task before or at day Ei. A machine can only work on one task at a time, and each task can be processed by at most one machine at a time. However, a task can be interrupted and processed on different
machines on different days.

Now she wonders whether he has a feasible schedule to finish all the tasks in time. She turns to you for help.

Input

On the first line comes an integer T(T<=20), indicating the number of test cases.

You are given two integer N(N<=500) and M(M<=200) on the first line of each test case. Then on each of next N lines are three integers Pi, Si and Ei (1<=Pi, Si, Ei<=500), which have the meaning described in the description. It is guaranteed that in a feasible
schedule every task that can be finished will be done before or at its end day.

Output

For each test case, print “Case x: ” first, where x is the case number. If there exists a feasible schedule to finish all the tasks, print “Yes”, otherwise print “No”.

Print a blank line after each test case.

Sample Input

2
4 3
1 3 5
1 1 4
2 3 7
3 5 9

2 2
2 1 3
1 2 2


Sample Output

Case 1: Yes

Case 2: Yes


Author

allenlowesy

Source

2010 ACM-ICPC Multi-University
Training Contest(13)——Host by UESTC

题意:工厂有m台机器,需要做n个任务。对于一个任务i,你需要花费一个机器Pi天,而且,开始做这个任务的时间要>=Si,完成这个任务的时间<=Ei。对于一个任务,只能由一个机器来完成,一个机器同一时间只能做一个任务。但是,一个任务可以分成几段不连续的时间来完成。问,能否做完全部任务。

诈一看,感觉是一道贪心题……这种题用网络流做的话,难都不在于网络流算法,而是建图的过程,因为这是一个很抽象的过程……这里我们建图的过程就是:把每一天和每个任务看做点。由源点到每一任务,建容量为pi的边(表示任务需要多少天完成)。每个任务到每一天,若是可以在这天做任务,建一条容量为1的边,最后,把每天到汇点再建一条边容量m。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 1111;
const int maxm = 505000;
const int INF = 0xfffffff;
int idx;
int cur[maxn],pre[maxn],dis[maxn],gap[maxn],aug[maxn],head[maxn];
struct Node
{
int u,v,w,next;
}edge[maxm];
void addEdge(int u,int v,int w)
{
edge[idx].u = u;
edge[idx].v = v;
edge[idx].w = w;
edge[idx].next = head[u];
head[u] = idx++;

edge[idx].u = v;
edge[idx].v = u;
edge[idx].w = 0;
edge[idx].next = head[v];
head[v] = idx++;
}
int SAP(int s,int e,int n)
{
int max_flow = 0,v,u = s;
int id,mindis;
aug[s] = INF;
pre[s] = -1;
memset(dis,0,sizeof(dis));
memset(gap,0,sizeof(gap));
gap[0] = n;
for(int i=0; i<=n; i++)
cur[i] = head[i];// 初始化当前弧为第一条弧
while(dis[s] < n)
{
bool flag = false;
if(u == e)
{
max_flow += aug[e];
for(v=pre[e]; v!=-1; v=pre[v])// 路径回溯更新残留网络
{
id = cur[v];
edge[id].w -= aug[e];
edge[id^1].w += aug[e];
aug[v] -= aug[e];// 修改可增广量,以后会用到
if(edge[id].w == 0) u = v;// 不回退到源点,仅回退到容量为0的弧的弧尾
}
}
for(id=cur[u]; id!=-1; id=edge[id].next)
{// 从当前弧开始查找允许弧
v = edge[id].v;
if(edge[id].w>0 && dis[u]==dis[v]+1) // 找到允许弧
{
flag = true;
pre[v] = u;
cur[u] = id;
aug[v] = min(aug[u], edge[id].w);
u = v;
break;
}
}
if(flag == false)
{
if(--gap[dis[u]] == 0) break;/* gap优化,层次树出现断层则结束算法 */
mindis = n;
cur[u] = head[u];
for(id=head[u]; id!=-1; id=edge[id].next)
{
v = edge[id].v;
if(edge[id].w>0 &&dis[v]<mindis)
{
mindis = dis[v];
cur[u] = id;// 修改标号的同时修改当前弧
}
}
dis[u] = mindis+1;
gap[dis[u]]++;
if(u != s) u = pre[u];// 回溯继续寻找允许弧
}
}
return max_flow;
}
int main()
{
int t,n,m,pi,si,ei;
int Max,sum,source,sink,vn;
scanf("%d",&t);
for(int cas=1; cas<=t; cas++)
{
idx = 0;
memset(head,-1,sizeof(head));
sum = 0,source = 0,Max = 0;
scanf("%d%d",&n,&m);
for(int i=1; i<=n; i++)
{
scanf("%d%d%d",&pi,&si,&ei);
sum += pi;
Max = max(Max,ei);
addEdge(source,i,pi);
for(int j=si; j<=ei; j++)
addEdge(i,n+j,1);
}
sink = n+Max+1;
vn = sink+1;
for(int i=1; i<=Max; i++)
{
addEdge(n+i,sink,m);
}
if(SAP(source,sink,vn) == sum)
printf("Case %d: Yes\n\n",cas);
else printf("Case %d: No\n\n",cas);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: