您的位置:首页 > 其它

poj EXTENDED LIGHTS OUT 1222 (高斯消元)

2016-02-27 14:33 417 查看
POJ
- 1222

EXTENDED LIGHTS OUT

Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u
Submit Status

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right
and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5.
For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 



The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance,
in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 



Note: 

1. It does not matter what order the buttons are pressed. 

2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 

3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 

four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 

Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light
is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must
be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0


Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1


Source

Greater New York 2002

 

//题意:

5*6的方阵上有30个灯,周围的上下左右4个灯会发生相应的变化,即由灭变亮,由亮变灭,如何操作使灯全灭。

 

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define N 110
using namespace std;
int equ,var;
int a

;
int x
;
int f_x
;
int f_num;
int T;
int gcd(int a,int b)//求最大公约数
{
return b?gcd(b,a%b):a;
}
int lcm(int a,int b)//求最小公倍数
{
return a/gcd(a,b)*b;
}
int gauss()
{
int i,j,k;
int max_r;
int ta,tb;
int f_x_num;
int f_index;
int Lcm,tmp;
int col=0;
for(k=0;k<equ&&col<var;k++,col++)
{
max_r=k;
for(i=k+1;i<equ;i++)
if(abs(a[i][col])>abs(a[max_r][col]))
max_r=i;
if(max_r!=k)
for(j=k;j<var+1;j++)//将两行互换位置
swap(a[k][j],a[max_r][j]);
if(a[k][col]==0)
{
k--;
continue;
}
for(i=k+1;i<equ;i++)
{
if(a[i][col])
{
Lcm=lcm(abs(a[i][col]),abs(a[k][col]));
ta=Lcm/abs(a[i][col]);
tb=Lcm/abs(a[k][col]);
if(a[i][col]*a[k][col]<0)
tb=-tb;
for(j=col;j<var+1;j++)
a[i][j]=((a[i][j]*ta-a[k][j]*tb)%2+2)%2;
}
}
}
//以上是化增广矩阵为行阶梯型矩阵
//以下是非递归回带过程
for(i=k;i<equ;i++)
if(a[i][col])
return -1;//证明无解
if(k<equ)
{
for(i=k-1;i>=0;i--)
{
f_num=0;
for(j=0;j<var;j++)
{
if(a[i][j]&&f_x[j])
{
f_x_num++;
f_index=j;
}
}
if(f_x_num>1)
continue;
tmp=a[i][var]%2;
for(j=0;j<var;j++)
if(a[i][j]&&j!=f_index)
tmp=((tmp-a[i][j]*x[j])%2+2);
x[f_index]=tmp;
f_x[f_index]=0;
}
return var-k;
}
for(i=var-1;i>=0;i--)
{
tmp=a[i][var]%2;
for(j=i+1;j<var;j++)
{
if(a[i][j])
tmp=((tmp-a[i][j]*x[j])%2+2);
}
if(tmp%a[i][i])
return -2;
x[i]=(tmp/a[i][i])%2;
}
return 0;
}
void import()
{
memset(a,0,sizeof(a));
memset(x,0,sizeof(x));
memset(f_x,1,sizeof(f_x));
for(int i=0;i<5;i++)
{
for(int j=0;j<6;j++)
{
if(i-1>=0)
a[i*6+j][(i-1)*6+j]=1;
if(i+1<=4)
a[i*6+j][(i+1)*6+j]=1;
if(j-1>=0)
a[i*6+j][i*6+j-1]=1;
if(j+1<=5)
a[i*6+j][i*6+j+1]=1;
a[i*6+j][i*6+j]=1;
scanf("%d",&a[i*6+j][30]);
}
}
}
void Export()
{
int tt=0;
printf("PUZZLE #%d\n",T++);
for(int i=0;i<var;i++)
{
tt++;
if(tt%6==0)
printf("%d\n",x[i]);
else
printf("%d ",x[i]);
}
}
int main()
{
int t;
T=1;
equ=30;var=30;
scanf("%d",&t);
while(t--)
{
import();
f_num=gauss();
Export();
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: