您的位置:首页 > 其它

1105. Spiral Matrix (25)

2016-02-27 13:49 429 查看
This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The
matrix has m rows and ncolumns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is
the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The
numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
#include <iostream>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
bool cmp(int a, int b){ return a>b; }
int main()
{
int len;
cin >> len;
int m, n;
vector<int> vec(len);
for (int i = 1; i <= sqrt(len); i++)
{
if (len%i == 0)
{
n = i;
m = len / i;
}
}
for (int i = 0; i<len; i++)
{
cin >> vec[i];
}
sort(vec.begin(), vec.end(), cmp);
vector<vector<int> > matrix(m);
for (int i = 0; i<m; i++)
{
matrix[i].resize(n);
}
for (int i = 0, loop = 0; i<len; loop++)
{
for (int i1 = loop; i1<n - loop&&i<len; i1++)
matrix[loop][i1] = vec[i++];
for (int i2 = loop + 1; i2<m - loop&&i<len; i2++)
matrix[i2][n - loop - 1] = vec[i++];
for (int i3 = n - loop - 2; i3 >= loop&&i<len; i3--)
matrix[m - loop - 1][i3] = vec[i++];
for (int i4 = m - loop - 2; i4>loop&&i<len; i4--)
matrix[i4][loop] = vec[i++];
}
for (int i = 0; i<m; i++)
{
for (int j = 0; j<n; j++)
{
if (j != n - 1)cout << matrix[i][j] << " ";
else cout << matrix[i][j] << endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat