您的位置:首页 > 其它

Soldier and Badges

2016-02-26 16:15 239 查看
Description

Colonel has n badges. He wants to give one badge to every of his
n soldiers. Each badge has a
coolness factor, which shows how much it's owner reached. Coolness factor can be increased by one for the cost of one coin.

For every pair of soldiers one of them should get a badge with strictly higher factor than the second one. Exact values of their factors aren't important, they just need to have distinct factors.

Colonel knows, which soldier is supposed to get which badge initially, but there is a problem. Some of badges may have the same factor of coolness. Help him and calculate how much money has to be paid for making all badges have different factors of coolness.

Input

First line of input consists of one integer n (1 ≤ n ≤ 3000).

Next line consists of n integers
ai (1 ≤ ai ≤ n), which stand for coolness factor of each badge.

Output

Output single integer — minimum amount of coins the colonel has to pay.

Sample Input

Input
4
1 3 1 4


Output
1


Input
5
1 2 3 2 5


Output
2


Sample Output

Hint

In first sample test we can increase factor of first badge by
1.

In second sample test we can increase factors of the second and the third badge by
1.

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>

using namespace std;

int main()
{
int n, i, j, x = 0, y, min, m;
int a[3000];
scanf("%d", &n);
for (i = 0; i < n; i++)
{
scanf("%d", &a[i]);

}

sort(a, a + n);
x = 0;
for (i = 1; i < n; i++)
{
if (a[i] <= a[i - 1])
{
m = a[i - 1] - a[i] + 1;
a[i] += m;
x += m;
}
}
printf("%d\n", x);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: