您的位置:首页 > 其它

【hdu2456】aggresive cow——二分

2016-02-26 14:52 225 查看
题目:

Aggressive cows

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9488Accepted: 4716
Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them
is as large as possible. What is the largest minimum distance?
Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output

* Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9

Sample Output
3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.
Source

USACO 2005 February Gold
描述:在一维数轴上选择n个数可以接受对象,有c个对象,要求分配对象使相邻两个数的距离最大,且不相邻。

题解:先对n个数排序,之后求出间距的最大值,然后二分枚举间距尝试即可。

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;

const int N = 100005;
int arr
;
int n, c;

bool jdg(int x)
{
int num = arr[0];
int i, j;
j = 0;
for (i = 1; i<c; i++)
{
num += x;
bool flag = false;
for (j++; j<n; j++)                  //由于退出是break,上一次查询并没有更新j,所以初始化时j++
if (num <= arr[j])           //经过距离x后的编号小于等于有牛的房间
{
num = arr[j];        //从这个房间起算
flag = true;
break;
}

if (flag == false)
return false;
}
return true;
}

int main()
{
//freopen ("input.txt", "r", stdin);
int i;
while (~scanf("%d%d", &n, &c))
{
for (i = 0; i<n; i++)
scanf("%d", &arr[i]);
sort(arr, arr + n);
int left, right, mid;
right = (arr[n - 1] - arr[0]) / (c - 1);
left = 0;
while (left <= right)
{
mid = (left + right) / 2;
if (jdg(mid))
left = mid + 1;
else
right = mid - 1;
}
printf("%d\n", right);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: