您的位置:首页 > 其它

hdu 1042 N!

2016-02-25 20:24 274 查看


Problem Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1

2

3

Sample Output

1

2


6

大数的阶乘

#include<iostream>
#define MAX 100000
using namespace std;
int main()
{
int n,a[MAX];
int i,j,k,count,temp;
while(cin>>n)
{
a[0]=1;
count=1;
for(i=1;i<=n;i++)
{
k=0;
for(j=0;j<count;j++)
{
temp=a[j]*i+k;
a[j]=temp%10;
k=temp/10;
}
while(k)
{
a[count++]=k%10;
k/=10;
}
}
for(j=MAX-1;j>=0;j--)
if(a[j])
break;
for(i=count-1;i>=0;i--)
cout<<a[i];
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: