您的位置:首页 > 产品设计 > UI/UE

POJ 3601-Subsequence【尺取法】

2016-02-25 17:25 323 查看
Subsequence

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10658Accepted: 4419
Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum
of which is greater than or equal to S.
Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The
input will finish with the end of file.
Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3

Source

Southeastern Europe 2006

题目基本上只这样的,给定长度为n的数列整数a0,a1…..an-1以及整数S。求出总和不小于S的连续子序列的长度的最小值。如果不存在输出0。

比如第一组数据5+10长度为二,第二组数据3+4+5长度为三。

先介绍一种方法:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,S;
int a[100000];
int sum[100000];

void solve()
{
int i;
for(i=0;i<n;i++)
{
sum[i+1]=sum[i]+a[i];
}
if(sum
<S)
{
printf("0\n");
return;
}
int res=n;
for(int s=0;sum[s]+S<=sum
;s++)
{
//利用二分搜索求出t
int t=lower_bound(sum+s,sum+n,sum[s]+S)-sum;
res=min(res,t-s);
}
printf("%d\n",res);
}

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int i,j;
scanf("%d%d",&n,&S);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
solve();
}
return 0;
}


用尺取法就会高效一点

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,S;
int a[100000];
int sum[100000];

void solve()
{
int res=n+1;
int s=0,t=0,sum=0;
for(;;)
{
while(t<n&&sum<S)
{
sum+=a[t++];
}
if(sum<S)
break;
res=min(res,t-s);
sum-=a[s++];
}
if(res>n)
res=0;
printf("%d\n",res);
}

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int i,j;
scanf("%d%d",&n,&S);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: