您的位置:首页 > 大数据 > 人工智能

HDOJ Train Problem I

2016-02-25 13:28 453 查看
Train Problem I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 28814 Accepted Submission(s): 10945

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one
railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train
B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the
trains can get out in an order O2.

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample
Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of
the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

3 123 321

3 123 312

Sample Output

Yes.

in

in

in

out

out

out

FINISH

No.

FINISH

首先一点要回懂得使用栈,c++里有现成的,这一题就是模拟这个过程,用ans数组存下操作,1表示in, 0表示out模拟就好了

//1--in, 0--out;
# include <stdio.h>
# include <string.h>
# include <algorithm>
# include <stack>
using namespace std;
stack<char> m;
char s[20];//原串
char d[20];//目的串
int ans[30];
int main(){
int length, n, _s, _d, count, flage;
char temp;
while(scanf("%d", &n)!=EOF){
scanf("%s", s);
scanf("%s", d);
length=strlen(s);
_d=0;//目的串的下标,即要得到的字符的下标
_s=0;//原串的下标,即将要入栈的数下标
count=0;//ans下表
flage=0;
while(!m.empty()){//初始化栈
m.pop();
}
while(_d<length){
if(m.empty()){//栈空,入栈并记录操作
m.push(s[_s]);
_s++;
ans[count++]=1;
}
else{
temp=m.top();
if(temp==d[_d]){//匹配成功则出栈
m.pop();
ans[count++]=0;
_d++;
}
else{//匹配不成功继续入栈
if(_s==n){//到终点无法继续入栈则退出, 输出No
flage=1;
break;
}
else{//未到达终点继续入栈
m.push(s[_s]);
ans[count++]=1;
_s++;
}
}
}
}
if(flage){
printf("No.\nFINISH\n");
}
else{
printf("Yes.\n");
for(int i=0; i<=count-1; i++){
if(ans[i]){
printf("in\n");
}
else{
printf("out\n");
}
}
printf("FINISH\n");
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: