您的位置:首页 > 其它

hdoj KK's Steel 5620 (打表)

2016-02-25 09:43 274 查看

KK's Steel

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 464    Accepted Submission(s): 224


[align=left]Problem Description[/align]
Our lovely KK has a difficult mathematical problem:he has a N(1≤N≤1018) meters
steel,he will cut it into steels as many as possible,and he doesn't want any two of them be the same length or any three of them can form a triangle.
 

[align=left]Input[/align]
The first line of the input file contains an integer T(1≤T≤10),
which indicates the number of test cases.

Each test case contains one line including a integer N(1≤N≤1018),indicating
the length of the steel.
 

[align=left]Output[/align]
For each test case, output one line, an integer represent the maxiumum number of steels he can cut it into.
 

[align=left]Sample Input[/align]

1
6

 

[align=left]Sample Output[/align]

3

Hint1+2+3=6 but 1+2=3 They are all different and cannot make a triangle.
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll long long
using namespace std;
ll a[110];
ll s[110];
int main()
{
int t,i,j;
ll n;
a[1]=1;a[2]=1;a[3]=2;
for(i=4;i<=100;i++)
a[i]=a[i-1]+a[i-2];
for(i=2;i<=100;i++)
s[i]=s[i-1]+a[i];
scanf("%d",&t);
while(t--)
{
scanf("%lld",&n);
for(i=2;i<100;i++)
{
if(s[i]>=n)
break;
}
if(s[i]==n)
printf("%d\n",i-1);
else
printf("%d\n",i-2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: