您的位置:首页 > 其它

POJ-3020

2016-02-24 22:06 429 查看
Antenna Placement

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 7995 Accepted: 3959

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them.

Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set [‘‘,’o’]. A ‘‘-character symbolises a point of interest, whereas a ‘o’-character represents open space.

Output

For each scenario, output the minimum number of antennas necessary to cover all ‘*’-entries in the scenario’s matrix, on a row of its own.

Sample Input

2

7 9

ooo**oooo

*oo*ooo

o*oo**o**

ooooooooo

*******oo

o*o*oo*oo

*******oo

10 1

*

*

*

o

*

*

*

*

*

*

Sample Output

17

5

Source

Svenskt Mästerskap i Programmering/Norgesmesterskapet 2001

分析:匈牙利算法,题目本质是个二分图,这里我把它当一般图处理了,不影响结果。

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int x,y,t,tot,num,ans,f[41][11],a[410],F[410];
struct thing
{
int n,next;
} b[2000];
bool jud[410];
char pos[41][11];
void insert(int x,int y)
{
tot++;
b[tot].n=y;
b[tot].next=a[x];
a[x]=tot;
}
bool Find(int x)
{
if(jud[x]) return false;
jud[x]=true;
int j=a[x];
while(j)
{
int y=b[j].n;
if(!F[y] || Find(F[y]))
{
F[y]=x;
F[x]=y;
jud[x]=false;
return true;
}
j=b[j].next;
}
return false;
}
int main()
{
cin.sync_with_stdio(false);
cin>>t;
for(int T=1;T <= t;T++)
{
tot=0,num=0,ans=0;
memset(pos,0,sizeof(pos));
memset(a,0,sizeof(a));
cin>>x>>y;
for(int i=1;i <= x;i++)
for(int j=1;j <= y;j++)
{
cin>>pos[i][j];
if(pos[i][j] == '*')
f[i][j]=++num;
}
for(int i=1;i <= x;i++)
for(int j=1;j <= y;j++)
{
if((pos[i][j] == '*') && (pos[i][j+1] =='*'))
insert(f[i][j],f[i][j+1]);
if((pos[i][j] == '*') && (pos[i][j-1] =='*'))
insert(f[i][j],f[i][j-1]);
if((pos[i][j] == '*') && (pos[i+1][j] =='*'))
insert(f[i][j],f[i+1][j]);
if((pos[i][j] == '*') && (pos[i-1][j] =='*'))
insert(f[i][j],f[i-1][j]);
}
memset(F,0,sizeof(F));
memset(jud,0,sizeof(jud));
for(int i=1;i <= num;i++)
{
memset(jud,0,sizeof(jud));
if(!F[i] && Find(i)) ans++;
}
cout<<num-ans<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: