您的位置:首页 > 其它

POJ 2386 Lake Counting

2016-02-24 17:19 375 查看
Lake Counting

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 19591Accepted: 9848
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output

* Line 1: The number of ponds in Farmer John's field.
Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3


搜索水题,不解释!

!!。!!!。

AC代码例如以下:

#include<stdio.h>
#include<string.h>

int x[8]={0,1,1,1,0,-1,-1,-1};
int y[8]={-1,-1,0,1,1,1,0,-1};
int n,m;
char b[105][105];

void sreach(int h,int z)
{
int i;
b[h][z]='.';
for(i=0;i<8;i++)
{
if(b[h+x[i]][z+y[i]]=='W')
sreach(h+x[i],z+y[i]);
}
}

int main()
{

int i,j,cont;
while(~scanf("%d %d",&n,&m))
{
memset(b,0,sizeof(b));
cont=0;
for(i=0;i<n;i++)
{
scanf("%s",b[i]);
}
for(i=0;i<n;i++)
for(j=0;j<m;j++)
{
if(b[i][j]=='W')
{cont++;sreach(i,j);}
}
printf("%d\n",cont);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: