您的位置:首页 > 其它

HDU1171(01背包均分问题)

2016-02-24 11:16 281 查看
Big Event in HDU
Time Limit:5000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u


Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2

10 1
20 1
3

10 1

20 2
30 1
-1

Sample Output

20
10

40
40

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[250005];
int n;
int w[50005];
int main()
{
while(scanf("%d",&n)!=EOF&&n>=0)
{
memset(dp,0,sizeof(dp));
int sum=0;
int v,num;
int cnt=0;
for(int i=0;i<n;i++)
{
scanf("%d%d",&v,&num);
sum+=num*v;
while(num)//将相同的设备分开
{
w[cnt++]=v;
num--;
}
}

for(int i=0;i<cnt;i++)
for(int j=sum/2;j>=w[i];j--)
dp[j]=max(dp[j],dp[j-w[i]]+w[i]);
int ans=max(dp[sum/2],sum-dp[sum/2]);
printf("%d %d\n",ans,sum-ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: