您的位置:首页 > 其它

POJ--2109 Power of Cryptography

2016-02-23 23:48 567 查看
[align=center]Power of Cryptography[/align]

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 21728Accepted: 10982
Description
Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches
of mathematics once considered to be only of theoretical interest.

This problem involves the efficient computation of integer roots of numbers.

Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is
what your program must find).
Input
The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn =
p.
Output
For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input
2 16
3 27
7 4357186184021382204544

Sample Output
4
3
1234
这题有毒~
为什么总有出题人想要谋害朕?
以下是我的AC代码:
二分查找
#include <stdio.h>
#include <math.h>
int main()
{
double n,p;
while(scanf("%lf%lf",&n,&p)!=EOF)
{
int begin=1;
int end=1000000000;
int mid;
while (begin <= end)
{
mid=(begin+end)/2;
double temp=pow(mid,n);
if (temp==p)
{
printf("%d\n",mid);
break;
}
else if(temp>p)
{
end=mid-1;
}
else
{
begin = mid + 1;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: