您的位置:首页 > 其它

poj 1163 the triangle(dp)

2016-02-23 22:38 411 查看
The Triangle

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 42757Accepted: 25834
Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.
Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

大致题意:比较简单==不说了
动态规划,记忆化搜索,当前状态是本层,前一个状态是上一层,具体直接见代码

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
int a[105][105],maxn=-1,f[105][105];
int solve(int i,int j)
{
if(f[i][j]!=0)return f[i][j];//记忆化搜索
else
{
if(i==0)return f[i][j]=a[0][0];
else
{
if(j>0)return f[i][j]=max(solve(i-1,j-1),solve(i-1,j))+a[i][j];
else if(j==i)return f[i][j]=solve(i-1,j-1)+a[i][j];
else return f[i][j]=solve(i-1,j)+a[i][j];
}
}
}

int main()
{
int n,i,j;
scanf("%d",&n);
for(i=0;i<n;i++)
{
for(j=0;j<=i;j++)
{
scanf("%d",&a[i][j]);
}
}
for(j=0;j<n;j++)
if(solve(n-1,j)>maxn)maxn=solve(n-1,j);
printf("%d\n",maxn);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: