您的位置:首页 > 其它

HDU 1686 Oulipo

2016-02-23 22:06 288 查看
本题地址:>here<

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

Sample Output

1

3

0

Source

华东区大学生程序设计邀请赛_热身赛

题解

我竟无语凝噎……

题目形式千变万化,然而它依然是个水题(不就是重复吗)

这是以前的代码,比较乱哈

#include<cstdio>
#include<cstring>
using namespace std;
#define MAX_T 1000010
char st1[MAX_T],st2[MAX_T];
int next1[MAX_T],next2[MAX_T];
int main() {
int T;
scanf("%d",&T);
while(T--) {
int ans=0;
memset(next1,0,sizeof(next1));
memset(next2,0,sizeof(next2));
scanf("%s%s",&st2[1],&st1[1]);
int l1=strlen(&st1[1]),l2=strlen(&st2[1]);
int j=0;
for(int i=2;i<=l2;i++) {
while(j>0&&st2[i]!=st2[j+1])
j=next2[j];
j++;
next2[i]=j;
if(st2[i]!=st2[j])
next2[i]=0,j=0;
}
j=0;
for(int i=1;i<=l1;i++) {
while(j>0&&st1[i]!=st2[j+1])
j=next2[j];
j++;
next1[i]=j;
if(st1[i]!=st2[j])
next1[i]=0,j=0;
}
for(int i=1;i<=l1;i++)
if(next1[i]==l2) ans++;
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: