您的位置:首页 > 其它

poj 2488 A Knight's Journey DFS

2016-02-23 10:09 519 查看
A Knight's Journey

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 37746Accepted: 12835
Description


Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a
p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the
chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题意:就是说一个骑士能够走得有八个方向,让你找到一种方法可以走满整个棋盘。输出的:按照字典序输出

思路:DFS,深搜每一个点,知道能够完整走出来

WA点:1.字典序,确定了八个方向的值,必须是int xx[8] = {-2,-2,-1,-1,1,1,2,2}; int yy[8] = {-1,1,-2,2,-2,2,-1,1};这样的

2.国际棋盘横是字母,竖是数字,写程序一定要按照这样的顺序,否则答案对也是WA的

这样理解了就很容易AC了

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>

using namespace std;

int n2,n1;
int gra[30][30];
int xx[8] = {-2,-2,-1,-1,1,1,2,2};
int yy[8] = {-1,1,-2,2,-2,2,-1,1};
int cas;
int tag;
char path[100];

void dfs(int x,int y,int tol) {
path[tol] = x+'A'-1;
path[tol+1] = '0'+y;
if((tol+2)/2 == n1*n2) {
tag = 1;
return;
}
for(int i = 0; i < 8; i++) {
int g = x+xx[i];
int h = y+yy[i];
if(g >= 1 && g <= n1 && h >= 1 && h <= n2&& !gra[g][h] && !tag) {
gra[g][h]  = 1;
dfs(g,h,tol+2);
gra[g][h]  = 0;
}
}
}

int main() {
scanf("%d",&cas);
for(int i = 1; i <= cas; i++) {
scanf("%d%d",&n2,&n1);
memset(gra,0,sizeof(gra));
memset(path,0,sizeof(path));
tag = 0;
gra[1][1] = 1;
dfs(1,1,0);
printf("Scenario #%d:\n",i);
if(tag) {
printf("%s\n",path);
} else {
printf("impossible\n");
}
if(i < cas) {
printf("\n");
}

}
return 0;
}


程序就是严密,之前写错八个方向,后来又搞错的横竖,虽然答案是对的,但就是WA哎!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: