您的位置:首页 > 大数据 > 人工智能

POJ1704--Georgia and Bob--staircase nim

2016-02-22 22:47 399 查看
Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:



Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint
that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

Given the initial positions of the n chessmen, can you predict who will finally win the game?

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second
line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.
Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.
Sample Input
2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output
Bob will win
Georgia will win

--------------------------

该分析来自poj的discuss,本人觉得解说完美:

> 这道题目可以对应一个Staircase NIM问题,只需要把两个棋子之间的间隔以及第一个棋子与左边界的间隔看作一堆石子,则一次操作一定是从一对石子中取出若干移到右边相邻的一堆中。这就是标准的Staircase-NIM问题。

> 具体的做法是:将所有奇数位置上的石子个数做XOR,结果为0说明BOB胜,否则说明GEORGIA胜,Not Sure显然是不会出现的。

#include<iostream>
#include<algorithm>
using namespace std;
int main(){
	int cas;
	cin>>cas;
	while(cas--){
		int n;
		int array[1005] = {0};
		cin>>n;
		for(int i = 1; i <= n; i++ ){
			cin>>array[i];
		}
		sort(array,array+n+1);//why?因为测试数据不一定从小到大给出 
		int temp;
		int sum = 0;
		for(int i = n; i > 0; i-=2 ){
			temp= array[i] - array[i-1] - 1;
			sum = sum^temp;
		}
		if(sum == 0) 
		    cout<<"Bob will win"<<endl;
		else 
		    cout<<"Georgia will win"<<endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: