您的位置:首页 > 其它

POJ 1222 EXTENDED LIGHTS OUT 高斯消元

2016-02-22 21:58 519 查看
点击打开链接

EXTENDED LIGHTS OUT

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 6492Accepted: 4267
Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right
and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5.
For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.



The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance,
in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.



Note:

1. It does not matter what order the buttons are pressed.

2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.

3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first

four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.

Write a program to solve the puzzle.
Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light
is on initially.
Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must
be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.
Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

Source

Greater New York 2002

给你一个5*6的矩阵。每一个矩阵单位里面都有一盏灯,你能够按下开关,使得此灯和周围的灯都改变状态,给你一个初始状态,让你求如何按才干使得全部的灯都灭。


能够定义30个未知数各自是x0,x1,x2,x3....x29代表每盏灯的开关是否被按。对于每一盏灯都能列一个方程式,对于在位置(i,j)的灯。能够列出:
x(i*6+j)+x(i*6+j+1)+x(i*6+j-1)+x((i+1)*6+j)+x((i-1)*6+j)=a%2 当中a为题中给出的初始开关的状态。
这样的方程能够列出30个,高斯消元就可以解出答案。


//140K	0MS
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<map>
#include<stack>
#include<queue>
#include<vector>

#pragma comment(linker, "/STACK:1024000000");
#define M 100007
#define inf 0x3f3f3f3f
#define ll long long
#define mod 1000000009
#define eps (1e-8)
using namespace std;
int matrix[37][37],id[37];
int dir[4][2]={{0,1},{1,0},{-1,0},{0,-1}};
void Guess(int n,int m)
{
int i=0,j=0;
while(i<n&&j<m)
{
int max_i=i;
for(int k=i+1;k<n;k++)
if(matrix[k][j]==1)
{
max_i=k;
break;
}
if(matrix[max_i][j])
{
if(max_i!=i)
for(int k=0;k<m;k++)
swap(matrix[max_i][k],matrix[i][k]);
for(int u=0;u<n;u++)
if(i!=u&&matrix[u][j])
for(int k=j;k<m;k++)
matrix[u][k]=matrix[u][k]^matrix[i][k];
i++;
}
j++;
}
}
int main()
{
int n,cas=1;
scanf("%d",&n);
while(n--)
{
memset(matrix,0,sizeof(matrix));
memset(id,0,sizeof(id));
for(int i=0;i<5;i++)
for(int j=0;j<6;j++)
{
scanf("%d",&id[i*6+j]);
matrix[i*6+j][30]=id[i*6+j];
}
for(int i=0;i<5;i++)
for(int j=0;j<6;j++)
{
matrix[i*6+j][i*6+j]=1;
for(int k=0;k<4;k++)
{
int x=i+dir[k][0];
int y=j+dir[k][1];
if(x>=0&&x<5&&y>=0&&y<6)
matrix[i*6+j][x*6+y]=1;
}
}
Guess(30,31);
printf("PUZZLE #%d\n",cas++);
for(int i=0;i<5;i++)
{
for(int j=0;j<6;j++)
printf("%d ",matrix[i*6+j][30]);
printf("\n");
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: