您的位置:首页 > 其它

poj 2349 Arctic Network

2016-02-22 21:06 316 查看
Arctic Network

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15277 Accepted: 4876
Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will
in addition have a satellite channel. 

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers.
Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in
km (coordinates are integers between 0 and 10,000).
Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750

Sample Output
212.13

Source

Waterloo local 2002.09.28

题意:国防部(DND)要用无线网络连接北部几个哨所。两种不同的通信技术被用于建立网络:每一个哨所有一个无线电收发器,一些哨所将有一个卫星频道。 

   任何两个有卫星信道的哨所可以通过卫星进行通信,而不管他们的位置。同时,当两个哨所之间的距离不超过D时可以通过无线电通讯,D取决于对收发器的功率。功率越大,D也越大,但成本更高。出于采购和维修的方便,所有哨所的收发器必须是相同的;那就是说,D值对每一个哨所相同。 

你的任务是确定收发器的D的最小值。每对哨所间至少要有一条通信线路(直接或间接)。

有 m 个哨所需要m-1条边连接,s颗卫星可以代替s-1条边,用卫星代替最长的边

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int father[550], m, k;
double d[550];
struct post
{
double x, y;
}p[550];
struct edge
{
int u, v;
double w;
}e[500005];
bool comp(edge e1, edge e2)
{
return  e1.w < e2.w;
}
double get_dis(double x1, double y1, double x2, double y2)
{
return sqrt((x1-x2)*(x1-x2) + (y1-y2)*(y1-y2));
}
void Init(int n)
{
for(int i = 1; i <= n; i++)
father[i] = i;
}
int Find(int x)
{
if(x != father[x])
father[x] = Find(father[x]);
return father[x];
}
void Merge(int a, int b)
{
int p = Find(a);
int q = Find(b);
if(p > q)
father[p] = q;
else
father[q] = p;
}
void Kruskal(int n)
{
k = 0;
double Max = 0;
for(int i = 0; i < m; i++)
if(Find(e[i].u) != Find(e[i].v))
{
Merge(e[i].u, e[i].v);
d[k++] = e[i].w;
n--;
if(n == 1)
return;
}
}
int main()
{
int t, S, P, i, j;
double x, y;
scanf("%d",&t);
while(t--)
{
m = 0;
scanf("%d%d",&S,&P);
Init(P);
for(i = 1; i <= P; i++)
scanf("%lf%lf",&p[i].x, &p[i].y);
for(i = 1; i <= P; i++)
for(j = i + 1; j <= P; j++)
{
e[m].u = i;
e[m].v = j;
e[m++].w = get_dis(p[i].x, p[i].y, p[j].x, p[j].y);
e[m].u = j;
e[m].v = i;
e[m++].w = get_dis(p[i].x, p[i].y, p[j].x, p[j].y);
}
sort(e, e+m, comp);
Kruskal(P);
printf("%.2lf\n",d[P-S-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: