您的位置:首页 > 编程语言 > C语言/C++

1027. Colors in Mars (20)

2016-02-21 17:37 447 查看
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only
difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the
left.

Sample Input
15 43 71

Sample Output
#123456


#include <iostream>
#include <cstdio>

using namespace std;

char table[] = {'0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C'};

string dec_to_13(int n){
string s;

do{
s = table[n%13] + s;
n /= 13;
}while(n);

if(s.size() < 2) s = '0' + s;

return s;
}

int main(){
int r,g,b;
scanf("%d%d%d", &r, &g, &b);

printf("#%s%s%s", dec_to_13(r).c_str(), dec_to_13(g).c_str(), dec_to_13(b).c_str());

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ PAT Colors in Mars