您的位置:首页 > 其它

hdu2028 Lowest Common Multiple Plus

2016-02-20 15:32 363 查看


Lowest Common Multiple Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 47472    Accepted Submission(s): 19668


Problem Description

求n个数的最小公倍数。

 

Input

输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。

 

Output

为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。

 

Sample Input

2 4 6
3 2 5 7

 

Sample Output

12
70

 

Author

lcy

 

水题,注意计算gcd里面不要爆了,两个先乘一块可能会炸。

#include<iostream>
#include<cstdio>
#include<string>
#include<sstream>
#include<cstdlib>
#include<cstring>
#include<cctype>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<deque>
#include<cmath>
#include<climits>
#include<list>
#include<utility>
#include<memory>
#include<cstddef>
#include<iterator>

using namespace std;
typedef long long LL;
const double pi = acos(-1.0);
///////////////////////////////
int gcd(int a, int b) {
if (b == 0) return a;
return gcd(b, a%b);
}

///////////////////////////////
int main(int argc, char**argv) {
//freopen("input.txt", "r", stdin);
//freopen("output.txt", "w", stdout);
////////////////////////////
int n;
int input1, input2;
int ans;
while (cin >> n) {

n--;
cin >> input1;
while (n--) {
cin >> input2;
ans = input1 / (gcd(input1, input2))*input2;
input1 = ans;

}
cout << ans << "\n";

}

////////////////////////////
//system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu