您的位置:首页 > 编程语言

hdu 1019 Least Common Multiple

2016-02-20 13:55 447 查看

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 42968    Accepted Submission(s): 16146


[align=left]Problem Description[/align]
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

[align=left]Input[/align]
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where
m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

[align=left]Output[/align]
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 

[align=left]Sample Input[/align]

2
3 5 7 15
6 4 10296 936 1287 792 1

 

[align=left]Sample Output[/align]

105
10296

#include<iostream>

#include<map>

#include<string>

#include<cstring>

#include<cstdio>

#include<cstdlib>

#include<cmath>

#include<queue>

#include<stack>

#include<vector>

#include<algorithm>

using namespace std;

#define N 100000

long long gcd(long long m,long long n)

{

    if(m<n) return gcd(n,m);

    if(n==0) return m;

    return gcd(m%n,n);

}

int main()

{

    int t;

    cin>>t;

    while(t--)

    {

        int m;

        long long a=1,b;

        cin>>m;

        for(int i=0;i<m;i++)

        {

            cin>>b;

            a=a*b/gcd(a,b);

        }

        cout<<a<<endl;

    }

    return 0;

}

注:

这里没必要建立数组,直接在接收数据的时候求出a和b的最小公倍数即可

在一开始,记a=1,求其最小公倍数
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  编程 acm 杭电 gcd