您的位置:首页 > 其它

poj seek the name,seek the fame

2016-02-19 16:06 344 查看
Seek the Name, Seek the Fame

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 15526Accepted: 7854
Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative
little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings
of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input
ababcababababcabab
aaaaa

Sample Output
2 4 9 18
1 2 3 4 5

Source
POJ Monthly--2006.01.22,Zeyuan Zhu
题目大意:求字符串s中所以前缀等于后缀的字符串的长度
kmp算法与失配函数的应用
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char s[4000003];
int n,m,len,t[4000003],ans[4000003];
void calc_t()
{
t[0]=-1; int j;
for (int i=0;i<len;i++)
{
j=t[i];
while (s[i]!=s[j]&&j!=-1)
j=t[j];
t[i+1]=++j;
}
}
int main()
{
while (gets(s))
{
len=strlen(s); memset(t,0,sizeof(t));
calc_t();
memset(ans,0,sizeof(ans)); int num=0;
ans[++num]=len;
int j=len;
while (j!=0)
{
ans[++num]=t[j];
j=t[j];
}
for (int i=num;i>=1;i--)
if (ans[i])
printf("%d ",ans[i]);
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: