您的位置:首页 > 其它

1094. The Largest Generation (25)

2016-02-19 10:07 519 查看
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family
members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated
by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1. 
Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:
9 4

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
vector<vector<int> > children;
int geration=0;
int members=-1;
void bfs(int s)
{
queue<int> que;
que.push(s);
int last=s;
int level=0;
int count=0;
int tail;
while(que.empty() == false)
{
int c=que.front();
que.pop();
count++;
for(int i=0;i<children[c].size();i++)
{
tail=children[c][i];
que.push(children[c][i]);
}
if(last == c)
{
level++;
last=tail;
if(members < count)
{
members=count;
geration=level;
}
count=0;
}
}
}
int main()
{
int n,m;
cin>>n>>m;
children.resize(n+1);
int id,k,child;
for(int i=0;i<m;i++)
{
cin>>id>>k;
for(int j=0;j<k;j++)
{
cin>>child;
children[id].push_back(child);
}
}
bfs(1);
cout<<members<<" "<<geration;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat