您的位置:首页 > 其它

南阳题目25-A Famous Music Composer

2016-02-19 00:28 393 查看


A Famous Music Composer

时间限制:1000 ms | 内存限制:65535 KB
难度:1

描述
Mr. B is a famous music composer. One of his most famous work was his set of preludes. These 24 pieces span the 24 musical keys (there are musically distinct 12 scale notes, and each may use major or minor tonality). The 12 distinct scale notes are:

A A#=Bb B C C#=DbD D#=Eb E F F#=Gb G G#=Ab
Five of the notes have two alternate names, as is indicated above with equals sign. Thus, there are 17 possible names of scale notes, but only 12 musically distinct notes. When using one of these as the keynote for a musical key, we can further distinguish
between major and minor tonalities. This gives 34 possible keys, of which 24 are musically distinct.
In naming his preludes, Mr. B used all the keys except the following 10, which were named instead by their alternate names:

Ab minor A# majorA# minor C# major Db minor
D# major D# minorGb major Gb minor G# major
Write a program that, given the name of a key, give an alternate name if it has one, or report the key name is unique.

输入Each test case is described by one line having the format "note tonality", where "note" is one of the 17 names for the scale notes given above, and "tonality" is either "major" or "minor" (quotes for clarify).
输出For each case output the required answer, following the format of the sample.
样例输入
Ab minor
D# major
G minor


样例输出
Case 1: G# minor
Case 2: Eb major
Case 3: UNIQUE


一道很简单的替换题,注意读懂题目!

A#=Bb
C#=Db D#=Eb F#=Gb
G#=Ab

注意出现这种字符串的时候要输出其替换形式即可!代码很长,是个水题!

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
int i,j,num=1;
char s1[20],s2[20];
while(scanf("%s%s",s1,s2)!=EOF)
{
if(strcmp(s1,"A#\0")==0)
{
printf("Case %d: Bb %s\n",num++,s2);
continue;
}
if(strcmp(s1,"C#\0")==0)
{
printf("Case %d: Db %s\n",num++,s2);
continue;
}
if(strcmp(s1,"D#\0")==0)
{
printf("Case %d: Eb %s\n",num++,s2);
continue;
}
if(strcmp(s1,"F#\0")==0)
{
printf("Case %d: Gb %s\n",num++,s2);
continue;
}
if(strcmp(s1,"G#\0")==0)
{
printf("Case %d: Ab %s\n",num++,s2);
continue;
}

if(strcmp(s1,"Bb\0")==0)
{
printf("Case %d: A# %s\n",num++,s2);
continue;
}
if(strcmp(s1,"Db\0")==0)
{
printf("Case %d: C# %s\n",num++,s2);
continue;
}
if(strcmp(s1,"Eb\0")==0)
{
printf("Case %d: D# %s\n",num++,s2);
continue;
}
if(strcmp(s1,"Gb\0")==0)
{
printf("Case %d: F# %s\n",num++,s2);
continue;
}
if(strcmp(s1,"Ab\0")==0)
{
printf("Case %d: G# %s\n",num++,s2);
continue;
}
printf("Case %d: UNIQUE\n",num++);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: