您的位置:首页 > 其它

HDU1711(KMP入门题)

2016-02-18 10:42 141 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17971 Accepted Submission(s): 7854


[align=left]Problem Description[/align]
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

[align=left]Input[/align]
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

[align=left]Output[/align]
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

[align=left]Sample Input[/align]

2

13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

[align=left]Sample Output[/align]

6
-1

#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN=1000005;
int a[MAXN],b[MAXN],next[MAXN];
int lena,lenb;
void getnext()
{
int i=0,j=-1;
next[0]=-1;
while(i<lenb)
{
if(j==-1||b[i]==b[j])
{
i++;
j++;
next[i]=j;
}
else    j=next[j];
}
}
int KMP()
{
getnext();
int i=0,j=0;
while(i<lena&&j<lenb)
{
if(j==-1||a[i]==b[j])
{
i++;
j++;
}
else    j=next[j];
}
if(j==lenb)    return i-j+1;
else    return -1;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(next,0,sizeof(next));
scanf("%d%d",&lena,&lenb);
for(int i=0;i<lena;i++)
scanf("%d",&a[i]);
for(int i=0;i<lenb;i++)
scanf("%d",&b[i]);
printf("%d\n",KMP());
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: