您的位置:首页 > 其它

poj2398 Toy Storage

2016-02-18 09:56 351 查看
Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his
parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 

Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 



We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.
Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m
(0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates
(Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.
Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space,
followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.
Sample Input
4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output
Box
2: 5
Box
1: 4
2: 1


poj2318加强版
poj2318  http://blog.csdn.net/lzr010506/article/details/50684023
只是中间的n个隔板未排序,输出的是装有i个玩具的区域的个数,其他完全一样

#include<iostream>
#include<cmath>
using namespace std;
const int Max = 105;
const double eps = 1e-8;

struct Point
{
double x, y;
}s[Max], e[Max];
int n;

double mult(Point p1, Point p2, Point p0)
{
return (p1.x - p0.x) * (p2.y - p0.y) - (p2.x - p0.x) * (p1.y - p0.y);
}

bool run(Point p1, Point p2)
{
if(abs(p1.x-p2.x) < eps && abs(p1.y-p2.y) < eps)
return false;
for(int i = 0; i < n; i ++)
if(mult(p1, p2, s[i]) * mult(p1, p2, e[i]) > eps) return false;
return true;
}

int main()
{
int t;
cin >> t;
for(int Z = 1; Z <= t; Z ++)
{
cin >> n;
for(int i = 0; i < n; i ++)
cin >> s[i].x >> s[i].y >> e[i].x >> e[i].y;
bool flag = false;
if(n < 3) flag = true;
for(int i = 0; i < n && !flag; i ++)
for(int j = i + 1; j < n && !flag; j ++)
{
if(run(s[i], s[j])) flag = true;
else if(run(s[i], e[j])) flag = true;
else if(run(e[i], s[j])) flag = true;
else if(run(e[i], e[j])) flag = true;
}
if(flag) cout << "Yes!" << endl;
else cout << "No!" << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: