您的位置:首页 > 其它

HDU2955 Robberies

2016-02-17 14:10 225 查看
Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

2

4

6

思路:初看像背包,但由于概率是小数,所以可以把钱当作V,不被抓概率当做D。f[v]表示在抢到v的钱时不被抓的最大概率。然后扫一遍看看哪个v符合条件。

代码:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <queue>
#include <climits>
#include <set>

using namespace std;

int main()
{
#ifdef LOCAL
freopen("in.txt","rb",stdin);
//freopen("out.txt","wb",stdout);
#endif // LOCAL
int t;
double f[10000+10];
scanf("%d",&t);
while(t--)
{
double prob,p[110];
int n,money[110];
scanf("%lf%d",&prob,&n);
memset(f,0,sizeof(f));
f[0]=1;
for(int i=1;i<=n;i++)
{
scanf("%d%lf",&money[i],&p[i]);
for(int j=10000;j>=money[i];j--)
if(f[j-money[i]]!=0)
f[j]=max(f[j],f[j-money[i]]*(1-p[i]));
}
for(int j=10000;j>=0;j--)
if(1-f[j]<=prob)
{
printf("%d\n",j);
break;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM dp