您的位置:首页 > 其它

poj 1797 Heavy Transportation(dijkstra)

2016-02-16 19:53 344 查看
Heavy Transportation

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 26747 Accepted: 7143
Description

Background 

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed
on which all streets can carry the weight. 

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's
place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing
of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for
the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output
Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany

题意:有n个城市,m条道路,每条道路上都有一个承载量,求从1到n的最大承载量,就是整条路的最大承载量

类似于求最短路,只是需要改变求最短路的条件,通过写这道题也加深了对dijkstra算法的理解

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int map[1010][1010],n,m;
int dijs()
{

int d[1010],vis[1010],v,i,j;
for(i=1;i<=n;i++)
{
vis[i]=0;
d[i]=map[1][i];

}
for(i=1;i<=n;i++)
{
int f=-1;
for(j=1;j<=n;j++)
if(!vis[j]&&d[j]>f)
{
f=d[j];
v=j;
}
vis[v]=1;
for(j=1;j<=n;j++)
{
if(!vis[j]&&d[j]<min(d[v],map[v][j]))
d[j]=min(d[v],map[v][j]);
}
}
return d
;
}
int main()
{
int p,a,b,c,i,j;
int k=1;
scanf("%d",&p);
while(p--)
{
scanf("%d%d",&n,&m);
for(i=0;i<=n;i++)
for(j=0;j<=n;j++)
map[i][j]=0;
for(i=1;i<=m;i++)
{
scanf("%d%d%d",&a,&b,&c);
map[a][b]=map[b][a]=c;
}
printf("Scenario #%d:\n",k++);
printf("%d\n\n",dijs());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: