您的位置:首页 > 其它

1031. Hello World for U (20)

2016-02-16 10:45 417 查看
时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h d

e l

l r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h !

e d

l l

lowor

#include<iostream>
#include<string>
using namespace std;
int main(){
freopen("in.txt","r",stdin);
string str;
getline(cin,str);
int N=str.size(),n1,n2;
n1=2,n2=N-2;
while(n2>n1+2&&n2>=5){
n2-=2;
n1++;
}
int i;
for( i=0;i<n1-1;i++)
{
int k=n2-2;
cout<<str[i];
while(k--) cout<<" ";
cout<<str[N-i-1]<<endl;
}
int t=N-i;
for(;i<t;i++)
cout<<str[i];
cout<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: