您的位置:首页 > 其它

1036. Boys vs Girls (25)

2016-02-15 09:23 585 查看
Boys vs Girls (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output “Absent” in the corresponding line, and output “NA” in the third line instead.

Sample Input 1:

3

Joe M Math990112 89

Mike M CS991301 100

Mary F EE990830 95

Sample Output 1:

Mary EE990830

Joe Math990112

6

Sample Input 2:

1

Jean M AA980920 60

Sample Output 2:

Absent

Jean AA980920

NA

#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
using namespace std;
struct node{
string name,id;
int grade;
node(string n,string i,int g){
name=n,id=i,grade=g;
}
};
int main(){
string girl="",boy="",bId,gId;
int g_girl=200,g_boy=0;
int n;
cin>>n;
while(n--){
string name,id;
char s;
int grade;
cin>>name>>s>>id>>grade;
if(s=='M'){
if(grade<g_girl){
g_girl=grade,gId=id,girl=name;
}
}
else{
if(grade>g_boy){
g_boy=grade,bId=id,boy=name;
}
}
}
bool flag=false;
if(boy!="")
cout<<boy<<" "<<bId<<endl;
else {
cout<<"Absent"<<endl;
flag=true;
}
if(girl!="")
cout<<girl<<" "<<gId<<endl;
else {
cout<<"Absent"<<endl;
flag=true;
}
if(flag) cout<<"NA"<<endl;
else cout<<g_boy-g_girl<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: