您的位置:首页 > 其它

poj 1419(求最大独立集)

2016-02-14 23:37 435 查看
Graph Coloring

Description
You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if
a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.



Figure 1: An optimal graph with three black nodes

Input
The graph is given as a set of nodes denoted by numbers 1...n, n <= 100, and a set of undirected edges denoted by pairs of node numbers (n1, n2), n1 != n2. The input file contains m graphs. The number m is given on the first line.
The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.
Output
The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible
optimal coloring. It is given by the list of black nodes, separated by a blank.
Sample Input
1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output
3
1 4 5

Source
Southwestern European Regional Contest 1995
最大独立集=补图的最大团

最大团=补图的最大独立集

此题即为求补图的最大团

概念补图:原图的所有边取反——存在的变不存在,不存在的变存在

#include<cstdio>
#include<cstring>
using namespace std;
const int N=105;
int ans,f
,set

,a

,tmp
,opt
,n;
bool dfs(int num,int dep)
{
int i,j;
if(!num)
{
if(dep>ans)
{
ans=dep;
for(i=1;i<=dep;i++)
opt[i]=tmp[i];
return 1;
}
return 0;
}
for(i=1;i<=num;i++)
{
if(dep+num-i+1<=ans)
return 0;
int u=set[dep][i];
if(dep+f[u]<=ans)
return 0;
int cnt=0;
for(j=i+1;j<=num;j++)
if(a[u][set[dep][j]])
set[dep+1][++cnt]=set[dep][j];
tmp[dep+1]=u;
if(dfs(cnt,dep+1))
return 1;
}
return 0;
}
int main()
{
int T,i,m,x,y,j;
scanf("%d",&T);
while(T--)
{
memset(a,1,sizeof(a));
memset(opt,0,sizeof(opt));
memset(tmp,0,sizeof(tmp));
scanf("%d%d",&n,&m);
while(m--)
{
scanf("%d%d",&x,&y);
a[x][y]=a[y][x]=0;
}
ans=0;
for(i=n;i>=1;i--)
{
int cnt=0;
for(j=i+1;j<=n;j++)
if(a[i][j])
set[1][++cnt]=j;
tmp[1]=i;
dfs(cnt,1);
f[i]=ans;
}
printf("%d\n",ans);
for(i=1;i<=ans;i++)
printf("%d ",opt[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: