您的位置:首页 > 其它

poj2231 2010.8.1

2016-02-13 18:08 405 查看
Moo Volume

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 11299 Accepted: 3177

Description

Farmer John has received a noise complaintfrom his neighbor, Farmer Bob, stating that his cows are making too much noise.

FJ's N cows (1 <= N <= 10,000) allgraze at various locations on a long one-dimensional pasture. The cows are verychatty animals. Every pair of cows simultaneously carries on a conversation (soevery cow is simultaneously MOOing at all of the N-1 other cows).
When cow iMOOs at cow j, the volume of this MOO must be equal to the distance between iand j, in order for j to be able to hear the MOO at all. Please help FJ computethe total volume of sound being generated by all N*(N-1) simultaneous MOOingsessions.

Input

* Line 1: N

* Lines 2..N+1: The location of each cow(in the range 0..1,000,000,000).

Output

There are five cows at locations 1, 5, 3,2, and 4.

Sample Input

5

1

5

3

2

4

Sample Output

40

Hint

INPUT DETAILS:

There are five cows at locations 1, 5, 3,2, and 4.

OUTPUT DETAILS:

Cow at 1 contributes 1+2+3+4=10, cow at 5contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is(10+10+6+7+7) = 40.

Source

USACO 2005 January Silver

分析:

水题,但是。。。

刚开始觉得太水了,暴力就能过。。。但是暴力是不行的。。后来搜了解题报告,发现,是一道递推+数学的题。。。。

1.先把牛的坐标从小到大排序;

2.牛i 和牛i-1 之间的这段距离,被用了的次数=这个距离的左边的牛数*这个距离右边的牛数;

3.把这些都加起来,*2,就是结果了。

很强,我都米想到。。。。一定要抓住本质。。。

Source Code

Problem: 2231 User: creamxcream

Memory: 216K Time: 16MS

Language: C++ Result: Accepted

Source Code

#include <iostream>
#include <algorithm>

using namespace std;

#define MAXN 10010

__int64 position[MAXN];
int n;

bool cmp(__int64 a,__int64 b)
{
return (a<b);
}

int main()
{
scanf("%d",&n);
memset(position,0,sizeof(position));
for(int i=1;i<=n;i++)
scanf("%I64d",&position[i]);
sort(position+1,position+n+1,cmp);
__int64 ans=0;
for(int i=2;i<=n;i++)
ans+=(position[i]-position[i-1])*(i-1)*(n-i+1);
printf("%I64d\n",ans*2);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: