您的位置:首页 > 其它

poj--1753--Flip Game(dfs好题)

2016-02-13 17:04 429 查看
[align=center]Flip Game[/align]

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37201 Accepted: 16201
Description
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each
round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example:

bwbw

wwww

bbwb

bwwb

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the
goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww

Sample Output
4

Source
Northeastern Europe 2000

一个4*4的矩阵,每个格子要么是黑色,要么是白的,目标是将全部的格子颜色统一,每次可以翻转一个格子,黑变白,白变黑,翻转的同时该格子的周围上下左右也会变颜色(有的话),问最少的步数,由题意易知每个格子最多翻转1次,最多的步数也就是16,状态就是有2的16次方种,枚举每一个可能的步数,每个格子可以翻转或者不翻转,

在达到枚举的步数时,判断一下颜色是否相同,总的思路就是一行一行枚举,一个一个尝试

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
bool map[6][6],flag;
int step;
int dx[5]={0,0,0,1,-1};
int dy[5]={1,-1,0,0,0};
bool is()
{
for(int i=1;i<=4;i++)
for(int j=1;j<=4;j++)
{
if(map[i][j]!=map[1][1])
return false;
}
return true;
}
void flip(int r,int c)
{
for(int i=0;i<5;i++)
{
int x=r+dx[i];
int y=c+dy[i];
map[x][y]=!map[x][y];
}
}
void dfs(int r,int c,int s)
{
if(s==step)
{
flag=is();
return ;
}
if(flag||r==5) return ;//一行一行进行枚举
flip(r,c);//如果r,c进行翻转,步数加一
if(c<4)
dfs(r,c+1,s+1);
else
dfs(r+1,1,s+1);
flip(r,c);//如果r,c处不翻转,就枚举下一个,flip要再用一次
if(c<4)
dfs(r,c+1,s);
else
dfs(r+1,1,s);
}
int main()
{
char c;
memset(map,false,sizeof(map));
flag=false;
for(int i=1;i<=4;i++)
for(int j=1;j<=4;j++)
{
cin>>c;
if(c=='b')
map[i][j]=true;
}
for(step=0;step<=16;step++)
{
dfs(1,1,0);
if(flag) break;
}
if(flag) cout<<step<<endl;
else cout<<"Impossible"<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: