您的位置:首页 > 其它

杭电1896 Stones(优先队列)

2016-02-13 13:25 351 查看

Stones

Time Limit: 5000/3000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 1596 Accepted Submission(s): 1020



[align=left]Problem Description[/align]
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.

There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell
me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

[align=left]Input[/align]
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.

For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position
of the i-th stone and how far Sempr can throw it.

[align=left]Output[/align]
Just output one line for one test case, as described in the Description.

[align=left]Sample Input[/align]

2
2
1 5
2 4
2
1 5
6 6


[align=left]Sample Output[/align]

11
12


[align=left]Author[/align]
Sempr|CrazyBird|hust07p43

[align=left]Source[/align]
HDU 2008-4 Programming Contest

[align=left]Recommend[/align]
lcy | We have carefully selected several similar problems for you:18921899

1895
1894
1897

Statistic |Submit |Discuss
|
Note
#include<stdio.h>
#include<queue>       \\ 使用队列头文件
using namespace std;
struct node{
int dis,far;
}s;
bool operator<(const node &x,const node &y)
{
if(x.dis==y.dis)  return x.far>y.far;
else return x.dis>y.dis;
}
int main()
{
int t,n,di,pi,k;
priority_queue<node>q; \\比较方式默认用operator<
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
while(n--)
{
scanf("%d%d",&di,&pi);
s.dis=di;
s.far=pi;
q.push(s); \\添加一个元素到优先队列中
}
k=1;
while(!q.empty())\\q.empty()优先队列为空时返回真,否则返回假;
{
s=q.top(); \\返回一个引用,指向最高优先级的元素
q.pop();   \\ 删除优先队列的第一个元素
if(1&k)    \\判断k是否为奇数
{
s.dis+=s.far;
q.push(s);\\是奇数的石头再放入队列中;
}
k++;
}
printf("%d\n",s.dis);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: