您的位置:首页 > 其它

1031. Hello World for U (20)

2016-02-12 22:32 375 查看
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:
h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters,
then left to right along the bottom line with n2 characters,
and finally bottom-up along the vertical line with n3 characters.
And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 =
n3 =
max { k| k <= n2 for
all 3 <= n2 <=
N } with n1 +
n2 +
n3 -
2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.
Sample Input:
helloworld!

Sample Output:
h   !
e   d
l   l
lower

确定各段的长度的方法见代码

#include <iostream>
#include <string>
#include <queue>
using namespace std;
int main()
{
string str;
cin >> str;
deque<char> que(str.begin(), str.end());
int n1, n2, n3;
n1 = n2 = n3 = (str.size()+2) / 3;
int add = (str.size()+2) % 3;
switch (add)
{
case 0:
break;
case 1:
n2=n2 + 1;
break;
case 2:
n2=n2 + 2;
break;
case 3:
n2=n2 + 1;
n1=n1 + 1;
n3=n3 + 1;
break;
}
string space(n2 - 2, ' ');
for (int i = 0; i < n1-1; i++)
{
cout << que.front();
que.pop_front();
cout << space;
cout << que.back()<<endl;
que.pop_back();
}
while (que.empty() == false)
{
cout<<que.front();
que.pop_front();
}
cout << endl;
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat