您的位置:首页 > 其它

【城会玩系列】hdu 5365 Run【计算几何相关】

2016-02-12 16:02 316 查看


Run

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1068    Accepted Submission(s): 471


Problem Description

AFA is a girl who like runing.Today,he download an app about runing .The app can record the trace of her runing.AFA will start runing in the park.There are many chairs in the park,and AFA will start his runing in a chair and end in this chair.Between two chairs,she
running in a line.she want the the trace can be a regular triangle or a square or a regular pentagon or a regular hexagon.

Please tell her how many ways can her find.

Two ways are same if the set of chair that they contains are same.

 

Input

There are multiply case.

In each case,there is a integer n(1 < = n < = 20)in a line.

In next n lines,there are two integers xi,yi(0 < = xi,yi < 9) in each line.

 

Output

Output the number of ways.

 

Sample Input

4
0 0
0 1
1 0
1 1

 

Sample Output

1

很有意识的一个题、开始觉得是想把所有边的长度都求出来,然后判断凸包,判断线段走向、极角排序啥的,合计老多了,完事我觉得这个题正确率这么高,不应该这么复杂,带着好奇心和急切的找到正确思路,我找到了官方题解。。。然后就没有然后了。。。

他们是这样给的题解:地球人都知道,整数点是不能构成正3.5,6边形的。。。。

然后默默暴力、、

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct zuobiao
{
int x,y;
}a[121];
int cal(int x,int y)
{
return x*x+y*y;
}
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
{
scanf("%d%d",&a[i].x,&a[i].y);
}
int output=0;
for(int i=0;i<n;i++)
{
for(int j=i+1;j<n;j++)
{
for(int k=j+1;k<n;k++)
{
for(int l=k+1;l<n;l++)
{
int d[6];
d[0]=cal(a[i].x-a[j].x,a[i].y-a[j].y);
d[1]=cal(a[i].x-a[k].x,a[i].y-a[k].y);
d[2]=cal(a[i].x-a[l].x,a[i].y-a[l].y);
d[3]=cal(a[j].x-a[k].x,a[j].y-a[k].y);
d[4]=cal(a[j].x-a[l].x,a[j].y-a[l].y);
d[5]=cal(a[k].x-a[l].x,a[k].y-a[l].y);
sort(d,d+6);
if(d[0]==d[1]&&d[1]==d[2]&&d[2]==d[3]&&d[4]==d[5]&&2*d[0]==d[4])
output++;
}
}
}
}
printf("%d\n",output);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 5365 杭电 5365