您的位置:首页 > 其它

UVA562(01背包均分问题)

2016-02-12 12:07 369 查看
Dividing coins
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu


Description

It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.

Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...

That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.

Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

Input

A line with the number of problems n, followed by n times:

a line with a non negative integer m (

) indicating the number of coins in the bag

a line with m numbers separated by one space, each number indicates the value of a coin.

Output

The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input

2
3
2 3 5
4
1 2 4 6


Sample Output

0
1

题意:给出n个硬币,将这些硬币分给两个人,使这两个人的硬币面值之差最小。

思路:尽可能的将硬币的面值平均分。

#include"cstdio"
#include"cstring"
#include"algorithm"
using namespace std;
const int MAXN=50005;
int n;
int w[MAXN];
int dp[MAXN];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(dp,0,sizeof(dp));
scanf("%d",&n);
int sum=0;
for(int i=0;i<n;i++)
{
scanf("%d",&w[i]);
sum+=w[i];
}
for(int i=0;i<n;i++)
{
for(int j=sum/2;j>=w[i];j--)    dp[j]=max(dp[j],dp[j-w[i]]+w[i]);
}
printf("%d\n",abs(sum-2*dp[sum/2]));
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: