您的位置:首页 > 其它

1025. PAT Ranking (25)

2016-02-11 20:30 288 查看
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your
job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then
K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
struct submit
{
string id;
int scores;
int location;
int final_rank;
int local_rank;
bool operator<(const submit & s)const{
if(scores > s.scores)return true;
else if(scores == s.scores && id < s.id)return true;
else return false;
}
};
int main()
{
int locations;
int k,begin=0,end;
cin>>locations;
vector<submit> submits;
submit s;
for(int i=0;i<locations;i++)
{
cin>>k;
for(int j=0;j<k;j++)
{
cin>>s.id>>s.scores;
s.location=i+1;
submits.push_back(s);
}
sort(submits.begin()+begin,submits.begin()+begin+k);
int grade=-1,rank;
for(int i=0;i<k;i++)
{
if(grade == submits[begin+i].scores)
{
submits[begin+i].local_rank=rank;
}
else
{
grade=submits[begin+i].scores;
rank=i+1;
submits[begin+i].local_rank=rank;
}
}

begin+=k;
}
sort(submits.begin(),submits.end());
int grade=-1,rank;
for(int i=0;i<submits.size();i++)
{
if(grade == submits[i].scores)
{
submits[i].final_rank=rank;
}
else
{
grade=submits[i].scores;
rank=i+1;
submits[i].final_rank=rank;
}
}
cout<<submits.size()<<endl;
for(int i=0;i<submits.size();i++)
{
printf("%s %d %d %d\n",submits[i].id.c_str(),submits[i].final_rank,submits[i].location,submits[i].local_rank);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat