您的位置:首页 > 大数据 > 人工智能

HDOJ 1789 Doing Homework again

2016-02-11 17:25 495 查看


Doing Homework again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10101 Accepted Submission(s): 5916



Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4


Sample Output

0
3
5


Author

lcy

Source

2007省赛集训队练习赛(10)_以此感谢DOOMIII

题意:Ignatius比赛回来之后,每位老师给Ignatius一个交作业的最后期限,如果交不上去就扣分。每门作业都要一天时间完成,求最少扣多少分。先输入一个T表示有T组测试数据,接下来每组数据先输入一个N,代表有N个作业,然后输入两行,第一行表示每门作业要交的日期,第二行表示对应的如果不交这门作业要扣的分数。输出要扣的最少分数。

此题也是比较基础的贪心题,这里我们采取的贪心策略为,先安排分数大的作业,并且尽量在靠完成时限越近的时间点完成。

#include <stdio.h>
#include <algorithm>
using namespace std;
struct home_work
{
int time;
int score;
};
bool cmp(home_work a,home_work b)
{
return a.score>b.score;
}
int main()
{
int T,N;
home_work work[1001];
scanf("%d",&T);
while(T--)
{
int i,j;
int flag,sum=0;
int mark[1001]={0};
scanf("%d",&N);
for(i=0;i<N;i++)
scanf("%d",&work[i].time);
for(i=0;i<N;i++)
scanf("%d",&work[i].score);
sort(work,work+N,cmp);
for(i=0;i<N;i++)
{
for(j=work[i].time,flag=0;j>0;j--)
{
if(mark[j]==0)
{
mark[j]=1;
flag++;
break;
}
}
if(flag==0)
sum+=work[i].score;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: