您的位置:首页 > 其它

hdoj 3336 Count the string 【KMP】

2016-02-11 10:07 357 查看


Count the string


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)


Total Submission(s): 7175 Accepted Submission(s): 3314

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"

The prefixes are: "a", "ab", "aba", "abab"

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1
4
abab


Sample Output

6


求前缀在字符串中出现的总次数~

AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define INF 0x3f3f3f3f
#define mod 10007
#define LL longlong
#include<algorithm>
using namespace std;
const int N = 200000+10;
char s
;
int p
;
int ls;
int num
;
void getp()
{
int i = 0, j = -1;
p[i] = j;
while(i < ls)
{
if(j==-1||s[i]==s[j])
{
i++, j++;
p[i] = j;
}
else  j = p[j];
}
}

int main()
{
int t; Si(t);
Wi(t){
Si(ls);
scanf("%s", s);
getp();
int sum = 0;
num[0] = 0;
for(int i = 1; i <= ls; i++)
{
num[i] = (num[p[i]]%mod + 1) % mod;
sum = (sum%mod + num[i]) % mod;
}
Pi(sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: