您的位置:首页 > 其它

POJ 3687 拓扑排序应用

2016-02-09 23:00 267 查看
Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

No two balls share the same label.
The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".
Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating
the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest
weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input
5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output
1 2 3 4
-1
-1
2 1 3 4
1 3 2 4
#include <IOSTREAM>
#include <QUEUE>
#include <CSTDLIB>
using namespace std;

#define NUM 201

int gmap[NUM][NUM];
int N,M;
int degree[NUM];
int value[NUM];
priority_queue<int> que;

bool tuopo()
{
int remain=N;
int ic;
for (ic=1;ic<=N;ic++)
{
if (degree[ic]==0)
que.push(ic);
}
if (que.size()==0)
return false;
while (que.size()!=0)
{
int node=que.top();
value[node]=remain--;
que.pop();
for (ic=1;ic<=N;ic++)
{
if (gmap[ic][node]==1)
{
gmap[ic][node]=-1;
degree[ic]--;
if (degree[ic]==0)
que.push(ic);
}
}
}
if (remain==0)
return true;
else
return false;
}
int main()
{
int a,b,T;
cin>>T;
while (T!=0)
{
memset(gmap,0,sizeof(gmap));
memset(degree,0,sizeof(degree));
memset(value,0,sizeof(value));
N=M=0;
cin>>N>>M;
while (M!=0)
{
cin>>a>>b;
if(gmap[a][b]==0)
{
gmap[a][b]=1;
degree[a]++;
}
M--;
}
if (tuopo())
{
for (int ic=1;ic<=N;ic++)
{
cout<<value[ic]<<" ";
}
cout<<endl;
}
else
cout<<"-1"<<endl;
T--;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: