您的位置:首页 > 其它

1008. Elevator (20)

2016-02-09 11:20 225 查看
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to
move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line. 
Sample Input:
3 2 3 1

Sample Output:
41

有一个问题是如果序列里有连续两个相同的数,那么应该停同一楼层两次,实际中应该是停留一次的时间,如果这样考虑的话不能AC,只能认为当两次楼层相同时停留10s。

#include <iostream>
#include <vector>
using namespace std;
int main()
{
int n;
cin>>n;
vector<int> vec(n);
for(int i=0;i<n;i++)
{
cin>>vec[i];
}
int total=0,last_floor=0;
for(int i=0;i<n;i++)
{
if(vec[i] >= last_floor)
{
total+=(vec[i]-last_floor)*6+5;
last_floor=vec[i];
}
if(vec[i] < last_floor)
{
total+=(last_floor-vec[i])*4+5;
last_floor=vec[i];
}
}
cout<<total<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat