您的位置:首页 > 其它

POJ 3070 矩阵的幂

2016-02-07 18:52 309 查看
Fibonacci

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 11873Accepted: 8432
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of
the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is


.
Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1

Sample Output
0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;

typedef long long ll;
typedef vector<int> vec;
typedef vector<vec> mat;

ll n;
const ll M = 10000;

mat mul (mat &a, mat &b){
mat c(a.size(), vec(b[0].size()));
for(int i = 0; i < a.size(); i++){
for(int k = 0; k < b.size(); k++){
for(int j = 0; j < b[0].size(); j++){
c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % M;
}
}
}
return c;
}

mat pow_mod(mat a, ll n){
mat b(a.size(), vec(a.size()));
for (int i = 0; i < a.size(); i++){
b[i][i] = 1;
}
while (n > 0){
if (n & 1) b = mul(b, a);
a = mul(a, a);
n >>= 1;
}
return b;
}

void solve(){
mat a(2, vec(2));
a[0][0] = 1, a[0][1] = 1;
a[1][0] = 1, a[1][1] = 0;
a = pow_mod(a, n);
printf("%d\n", a[1][0]);
}

int main(){
while(scanf("%I64d", &n) && n != -1){
solve();
}
return 0;
}
</vec></int></vector></cstring></algorithm></cstdio>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: