您的位置:首页 > 其它

hdu5086——Revenge of Segment Tree

2016-02-06 18:45 441 查看

Revenge of Segment Tree

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 383 Accepted Submission(s): 163



[align=left]Problem Description[/align]
In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content
cannot be modified once the structure is built. A similar data structure is the interval tree.

A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.

---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.

[align=left]Input[/align]
The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]

1. 1 <= T <= 10

2. 1 <= N <= 447 000

3. 0 <= Ai <= 1 000 000 000

[align=left]Output[/align]
For each test case, output the answer mod 1 000 000 007.

[align=left]Sample Input[/align]

2
1
2
3
1 2 3


[align=left]Sample Output[/align]

2
20
HintFor the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20.
Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded.
And one more little helpful hint, be careful about the overflow of int.


[align=left]Source[/align]
field=problem&key=BestCoder+Round+%2316&source=1&searchmode=source">BestCoder Round #16

[align=left]Recommend[/align]
heyang | We have carefully selected several similar problems for you: 5089 5088 5085 5084 5082

显然枚举全部区间是不可能的,我们得找找规律什么的,能够发现,设全部数的和是sum, S1(区间长度为1)的是sum,S2 = 2 * sum - (a1 + an)

S3 = 3 * sum - (2 * a1 + a2 + 2 *an + a1)

再枚举几个就能够找到规律

所以,总的和里。从左往右看 a1出现了(n-1)*n/2次,a2是(n - 2)*(n - 1)/2次........................

从右往左看,an出现了(n-1)*n/2次,an-1是(n - 2)*(n - 1)/2次........................

所以在O(n)的时间里就完毕了计算。注意用__int64以及取模

#include <map>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

__int64 a[447100];
__int64 b[447100];
const __int64 mod = 1000000007;

int main()
{
int t, n;
scanf("%d", &t);
while (t--)
{
scanf("%d", &n);
__int64 ans = 0, x;
__int64 sum = 0;
for (int i = 1; i <= n; i++)
{
scanf("%I64d", &x);
b[i] = x;
a[i] = (__int64)(n - i) * (1 + n - i) / 2 % mod;
sum += x;
sum %= mod;
}
for (int i = 1; i <= n; i++)
{
a[i] = (__int64)a[i] * b[i] % mod;
}
for (int i = n; i >= 1; i--)
{
a[i] += (__int64)(i - 1) * i  / 2 % mod * b[i] % mod;
}
ans = (__int64) n * (n + 1) / 2 % mod * sum % mod;
for (int i = 1; i <= n; i++)
{
ans -= a[i];
ans %= mod;
if (ans < 0)
{
ans += mod;
}
ans %= mod;
}
printf("%I64d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: