您的位置:首页 > 其它

POJ 3069

2016-02-06 17:39 302 查看
Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units,
and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units
of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s
army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positionsx1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n =
−1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output
2
4
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
int R, n;
vector<int> troop;
while (cin >> R >> n)
{
if (R == -1 && n == -1)
break;
troop.clear();
int temp, total = 0;
for (int ic = 0; ic < n; ic++)
{
cin >> temp;
troop.push_back(temp);
}
sort(troop.begin(), troop.begin() + n);
vector<int>::iterator itr = troop.begin();
while (itr != troop.end())
{
int left = *itr++;
while (itr != troop.end() && (*itr-left) <= R)
itr++;
int p = *(--itr);
while (itr != troop.end() && (*itr-p) <= R)
itr++;
total++;
}
cout << total << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: