您的位置:首页 > 其它

集训队专题(3)1001 Arbitrage

2016-02-05 00:20 801 查看


Arbitrage

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6037 Accepted Submission(s): 2797



Problem Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear.
The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency.
Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0


Sample Output

Case 1: Yes
Case 2: No


Source

University of Ulm Local Contest 1996

此题把汇率看做路程就可以将此题转换成最短(长)路径问题,由于此题需要知道每一种货币和自己的最大转换,所以这里我们最好用Floyd算法,当然能用这种算法还有一个最大的原因是此题的数据比较弱,Floyd算法的复杂度为O(n^3),而此处的n最大只有30(当然Floyd算法的核心算法代码只有5行,写起来如此方便,当然优先选这个^v^~)

#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
map<string, int> Map;
const int maxn = 35;
double G[maxn][maxn];
string str;
int n;
void Floyd()
{
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
for(int k=1; k<=n; k++)
if(G[j][k] < G[j][i]*G[i][k])
G[j][k] = G[j][i]*G[i][k];
}
int main()
{
int t=1;
while(scanf("%d",&n) && n)
{
memset(G,0,sizeof(G));
Map.clear();
for(int i=1; i<=n; i++)
{
cin >> str;
Map[str] = i;
}
int m;
scanf("%d",&m);
while(m--)
{
string a,b;
double rate;
cin >> a >> rate >> b;
int x = Map[a];
int y = Map[b];
G[x][y] = rate;
}
Floyd();
bool ok = 0;
for(int i=1; i<=n; i++)
if(G[i][i] > 1)
{
ok = 1;
break;
}
if(ok) printf("Case %d: Yes\n",t++);
else printf("Case %d: No\n",t++);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: