您的位置:首页 > 其它

Poj 1916 Period KMP

2016-02-04 22:33 393 查看
Period

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 15425 Accepted: 7394
Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is
one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 

number zero on it.
Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing
order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0

Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source
Southeastern Europe 2004
  思路:简单题目,KMP算法的简单应用,求一个串的前缀是否是循环串,是就输出,根据循环串的判断条件以及KMP算法中next数组的特性可以知道对于一个串来说,假如len=i-next[i] && i%len==0,那么当前就满足条件,不过这里要注意如果i==len 也就是next[i]==0,也就是没有循环串的话是满足条件的,加一个判断。
  AC代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn=1000000+5;
char x[maxn];
int next[maxn];

void getNext(int len){

int i=0,j=-1;
//memset(next,0,sizeof(next));
next[0]=-1;
while(i<len){
if(j==-1 || x[i]==x[j]){
i++,j++;
next[i]=j;
}
else j=next[j];
}
}

int main(){

int n;
int icase=0;
while(scanf("%d",&n)==1 && n){
scanf("%s",&x);
icase++;
getNext(n);
printf("Test case #%d\n",icase);
for(int i=1;i<=n;i++){
int len=i-next[i];
if(next[i]!=0 && i%len==0){
printf("%d %d\n",i,i/len);
}
}
printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  KMP POJ 1961 Period ACM