您的位置:首页 > 其它

poj2230——Watchcow(遍历有向欧拉图)

2016-02-04 17:45 141 查看
Description

Bessie’s been appointed the new watch-cow for the farm. Every night, it’s her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she’s done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she’s seen everything she needs to see. But since she isn’t, she wants to make sure she walks down each trail exactly twice. It’s also important that her two trips along each trail be in opposite directions, so that she doesn’t miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

Line 1: Two integers, N and M.

Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5

1 2

1 4

2 3

2 4

3 4

Sample Output

1

2

3

4

2

1

4

3

2

4

1

题目给的是遍历无相欧拉图,但要求是每条边必须来回遍历两次,所以可以化成有向欧拉图的遍历,注意容器类的用法

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<vector>
const int maxcost=10010;
using namespace std;
struct EDGE
{
int v;
bool vis;
};
vector<EDGE> vec[maxcost];
void dfs(int x)
{
for(int i=0;i<vec[x].size();++i)
{
if(!vec[x][i].vis)  //如果从x到i的有向通路没有被遍历
{
vec[x][i].vis=true;
dfs(vec[x][i].v);  //可以遍历下个顶点
}
}
printf("%d\n",x);
}
int main()
{
int u,v,m,n;
EDGE temp;
while(~scanf("%d%d",&n,&m))
{
while(m--)
{
scanf("%d%d",&u,&v);
temp.v=v;
temp.vis=false;
//互相建立有向通路
vec[u].push_back(temp);
temp.v=u;
vec[v].push_back(temp);
}
dfs(1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: