您的位置:首页 > 其它

杭电1060 Leftmost Digit

2016-02-04 00:14 489 查看

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15566 Accepted Submission(s): 6048



[align=left]Problem Description[/align]
Given a positive integer N, you should output the leftmost digit of N^N.

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

[align=left]Output[/align]
For each test case, you should output the leftmost digit of N^N.

[align=left]Sample Input[/align]

2
3
4


[align=left]Sample Output[/align]

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is2这个n^n很大,所以考虑用对数求,假设a为n^n的最左为,n^n=a*10^m,两边取对数n*lgn=m+lga;a=10^(n*lgn-m),可以看出m为n*lgn的整数部分,所以可以使用强制转由你n*lgn得到m[code]#include<stdio.h>
#include<math.h>
int main()
{
int a,t;
long long n;
double s;
scanf("%d",&t);
while(t--)
{
scanf("%lld",&n);
s=n*log10(n);
a=1*pow(10,s-(long long)s);
printf("%d\n",a);
}
return 0;
}

[/code]

[align=left]Author[/align]
Ignatius.L

[align=left]Recommend[/align]
We have carefully selected several similar problems for you:

1061
1071
1573
1066
1005

Statistic |
Submit |
Discuss |
Note

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: